ManMachine
@max@manmachine.me
@jsatk I like languages that are *stable* and don't require me to have 7 different versions installed at once.
"AI is built on the collective knowledge of humankind."
No. Nononononono. It is not built on _knowledge_, it it built on _data_. And not everyone's experiences are available as data, many communities are excluded. Also: "Collective" implies some sort of collaboration and shared activity. But "AI" is just accumulation by a few powerful.
So No. It's not collective but extractive, not knowledge but data, not humankind but the hegemonic western view. Everything in that statement is wrong.
This textbox is a message and part of a system of messages. Java is installed on over three billion devices. Java is found everywhere, even in your car. We thought we were a powerful culture.
It's so weird that a lot of people think the quality of software is measured in how often it gets updated—it's literally the opposite.
[…] I’m anti-the branding of it as “artificial intelligence”, because it’s not intelligent. It’s a form of machine learning. “Generative AI” is just a very good Markov chain that people expect far too much from.
it has been 0️⃣ days since I had to send a corporation a nastygram about disrespecting my “reduce motion” and “do not autoplay videos” accessibility settings
from an article about the bitcoin crash: “Bitcoin is crashing hard, reaching historic lows of well below the $70,000 mark. At the time of writing, the token is hovering just above $63,000, levels we haven’t seen since October 2024.”
Given that I personally remember people being excited that bitcoin had reached the mark of one (1) dollar, the term “historic lows” to describe returning to the state of things slightly over one year ago is rather telling about the tech industry’s lack of perspective and cultural memory…
(it’s still dropping though 😌)
@rasterweb I'm also trying to stop using "amateur" to mean sloppy and "professional" to mean high quality. That has always been a shitty dichotomy, and deskilling is only going to make it worse.
It doesn't matter whether C is good or not. It matters that if I write code in two languages that aren't C, and I want it to all be part of the same process, I need to care about C. C pervades all. You cannot escape it. C will outlive all of us. The language will die and the ABI will persist. The far future will involve students learning about C just to explain their present day. Our robot overlords will use null terminated strings. C will outlive fungi.
I just want to remind you that in 1992, the Internet cost $2.50 an hour to access ($4.00 after the first four hours a night), was three million times slower than WiFi, and nobody in your house could take phone calls while you used it. Doomscroll on THAT.
@inthehands Time Machine on two removable USB drives. One lives in your house and gets connected regularly; one lives somewhere else and you back up to that once or twice a year. All other answers are incorrect.
@fanf so, RFC 5966 said SHOULD, RFC 7766 turned it into MUST, and they still had to publish an even _more_ emphatic RFC 9210?
"The key words 'SHOULD', 'MUST', and 'GOOD GRIEF WHAT IS WRONG WITH YOU HOW CAN WE MAKE THIS ANY CLEARER' are to be interpreted …"